Mac OS X - krotíme Classic - MujMAC.cz - Apple, Mac OS X, Apple iPod

Odběr fotomagazínu

Fotografický magazín "iZIN IDIF" každý týden ve Vašem e-mailu.
Co nového ve světě fotografie!

 

Zadejte Vaši e-mailovou adresu:

Kamarád fotí rád?

Přihlas ho k odběru fotomagazínu!

 

Zadejte e-mailovou adresu kamaráda:

Soutěž

Sponzorem soutěže je:

IDIF

 

Odkud pochází fotografka Anne Erhard?

V dnešní soutěži hrajeme o:

Seriály

Více seriálů



Začínáme s

Mac OS X - krotíme Classic

MacOSX_class

20. února 2002, 00.00 | Mnoho uživatelů, používajících českou verzi Mac OS 9, má problém s fungovaním vrstvy Classic pod Mac OS X. V dnešním článku vám mimo jiné poradíme, jak si můžete opravit tento problém.

Jedním z poměrně častých dotazů čerstvých uživatelů Mac OS X je, jak zprovoznit vrstvu Classic, pokud používají Mac OS 9 CZ.

Classic není nic jiného, než "systém v systému", pod kterým se spouštějí aplikace, nekompatibilní s Mac OS X, konkrétně se používá Mac OS 9.1 a vyšší (Mac OS 9.0.x nelze použít). Díky tomu můžete používat všechny aplikace, které ještě nemají svou odpovídající verzi pro Mac OS X, což je například významná část programů pro DTP. Fakticky tedy budete pracovat v Mac OS 9, ovšem uvidíte z něj pouze část - menu a okna aktivní aplikace, ale nikoliv plochu či okna ve Finderu. Protože se jedná o Mac OS 9, budete také používat jiné rozhraní než v Mac OS X - okna, dialogy pro otevírání a ukládání souborů, tiskové dialogy a další. Také přístup k síti či volba tiskárny funguje přes Připojení. Je potřeba počítat s tím, že některé periferie nebudou pod Mac OS 9 fungovat, některé však ano. V připadě problémů nebo pochybností je ideální se obrátit na výrobce, většina jich má na webu sekci věnovanou kompatibilitě s Mac OS X.

Pokud chcete provozovat Classic na svém počítači, připravte se na to, že je relativně paměťôvě náročný - 256 MB je v tom případě opravdu minimum.

Vraťme se však k problému zmiňovaném na začátku, kdy uživatelé používající Mac OS 9.1 CZ nebo novější nemohou Classic pustit. Problém s Classicem je v tom, že odmítá "nabootovat" Mac OS 9, který má jako primární CE skript, tedy skript určený pro střední Evropu, podporující češtinu, slovenštinu, polštinu a maďarštinu. Rada je poměrně jednoduchá, je potřeba systém upravit tak, aby byl primární skript románský (Roman). Primární skript určuje, jak se systém bude chovat v oblasti podpory národnostních specifik, tedy například abecední řazení, formáty času, podpora písem ve Finderu a v některých menu.

Změna je velmi snadná - stačí k tomu ovládací panel od Applu, který je známý jako Script Switcher. Jedná se o vyloženě programátorskou, či spíš lokalizátorskou utilitku, běžný uživatel obvykle nemá potřebu měnit primární skript svého systému. Script Switcheru lze stáhnout ze serveru Apple, po rozbalení a otevření se objeví mapka a menu s oblastmi. Většina uživatelů bude mít aktivní pouze dvě položky, a to Roman (na prvním místě) a další takřka na konci seznamu - Ethiopic. To reprezentuje, ač vás to asi překvapí, Central Europe. Jak vidíte, náš region nikdy neměl u Applu na růžích ustláno.

Položka Ethiopic je zaškrtnutá jako aktivní, zvolte tedy v menu Roman. Script Switcher vás vyzve k brzkému restartu - a to je vše! Změny se pochopitelně projeví až po restartu, případně po spuštění Classicu pod Mac OS X.

Možná vás zajímá jaké následky tím ponesete - jaké aplikace přestanou fungovat a podobně. Systém by se měl chovat obdobně jako Mac OS 9 v International verzi s českou klávesnicí - tedy v podstatě bez problémů. Podle našich informací je jednou z citlivých aplikací Quark 3.x, Quarku 4.x Passport by to mělo být zcela jedno. Pokud chcete provozovat svůj legálně zakoupený QuarkXPress Passport 4.1 s USB klíčem pod Classicem, musíte si stáhnout novější verzi ovladače pro tento USB klíč. Máte li ADB klíč, máte také smůlu - ten není žádným způsobem pod Mac OS X podporovaný, ani v Classic vrstvě. Klíč je možné za úplatu vyměnit u distributora.

Jedním z dalších průvodních jevů může být ztráta češtiny v menu u některých aplikací a také to, že se vám bude vnucovat jako primární US klávesnice. Některé aplikace také mají pod Classice problémy s vykreslováním některých svých částí, případně obecně problémy s chodem - o problémech obvykle najdete informace na webech výrobců.

Pokud chcete Mac OS 9 pod OS X pouze vyzkoušet, může toto řešení pro vás být poměrně vyhovující, pro normální práci si prostě přepnete script zpět na CE. Toto řešení však není vyhovující pokud budete přecházet mezi oběma systémy častěji - v tom případě nemusí být na škodu mít zvlášť instalaci Mac OS 9 pouze pro použití v Classic vrstvě. O tom, jak takovýto systém použít a také jak bezpečně přecházet mezi různými systémy si povíme v některém z příštích článků.

Tématické zařazení:

 » Rubriky  » Mac OS X CZ  

 » Rubriky  » Informace  

 » Rubriky  » Agregator  

 » Rubriky  » Začínáme s  

Diskuse k článku

 

Vložit nový příspěvek   Sbalit příspěvky

 

ztráta češtiny

Autor: ushneek Muž

Založeno: 20.02.2002, 08:14
Odpovědí: 0

Možná by bylo snadnější (pokud už někomu nedělá problémy používat anglický OS X) naistalovat US, nebo International English 9.1 a umožnit používání češtiny CE Language Kitem. Já osobně jsem nikdy lokalizovaným verzím systému příliš nevěřil (něco je v lokalizovaném systému prostě nefunkční - např. Aktualizace sofware) a používám právě international - běží mi všechno korektně - čeština v systému, v menu aplikací, QXP 3.X... Mám instalovaný Script Switcher v 9.1 international právě ze sady CE Language Kit, kde je položka již tvůrcem upravena (pravděpodobně jen zásahem do resourcu) z Ethiopic na Central Europe. Ztráta češtiny v menu u některých aplikací se dá někdy vyřešit pomocí aplikace Language register, která umí určeným aplikacím vnutit zvolený skript jako primární. Je taktéž součástí CE Kitu. Kdysi jsem zde nalezl odkaz ke stažení: http://www.volny.cz/info-
apple/download/
Počít
m tedy, že by spouštění ani používání takto ošetřeného international systému 9.1 nemělo pod Classic vrstvou dělat potíže.

Odpovědět na příspěvek

RE: ztráta češtiny

Autor: agent Muž

Založeno: 21.02.2002, 00:30

CE Language Kit pouziva novejsi verzi Script Switcheru, ta jiz ma CE a navic ma i potvrzovaci dialog, ta puvodni verze by nemela byt pouzivana na systemu 8.1 a vyse...
CE Language Kit byl puvodne vytvoren jako X-kompatibilni, ale zatim sem to fakt netestoval, ale napr. po instalaci je jako hlavni script roman a cestina i presto funguje v 99% aplikaci.

Odpovědět na příspěvek

.. je mi to líto ..

Autor: miShow Muž

Založeno: 20.02.2002, 10:01
Odpovědí: 0

.. ale, ač se pokládám za zapřísáhlého "jablíčkáře", nemohu si odpustit poznámku, že do té doby, než bude všechen osvědčený (a to především QXP) DTP software fungovat pod osX, většina lidí zůstane věrná starému systému. A to nejen kvůli relativně menším nárokům na stroje, ale především kvůli takovýmhle problémům, které zde popisujete. Prostě pro je ještě příliš brzy. PS: Ale je hrozně fajn, že tomu tady věnujete tolik prostoru .. :o) Ne tak často člověk může být takřka u "zrodu" něčeho podobného .. :o)

Odpovědět na příspěvek

RE: .. je mi to líto ..

Autor: ushneek Muž

Založeno: 20.02.2002, 10:39

hm, taky myslim, ale zase jde víceméně o regionální záležitost. být v USA, tak už s tim klidně experimentuju i DTP. V QXP dělám od roku 94 a kvůli OS X vážně uvažuju nad přechodem k InDesign. Tak jako tak nechci lokalizovanou X, stačí podpora pro vstup a výstup CE. Já do desítky nejdu 1. kvůli stroji 2. kvůli (zatím) nedoladěnosti a neustálému windowslike updatování

Odpovědět na příspěvek

.. souhlas ..

Autor: miShow Muž

Založeno: 20.02.2002, 11:09

.. souhlasím .. jen na Indesign mám trochu jinej názor .. :o) .. ale to snad neva .. :o)

Odpovědět na příspěvek

Diky...

Autor: Mates Muž

Založeno: 20.12.2004, 20:05
Odpovědí: 0

...diky. Funguje to.

Odpovědět na příspěvek

 

 

Vložit nový příspěvek

Jméno:

Pohlaví:

,

E-mail:

Předmět:

Příspěvek:

 

Kontrola:

Do spodního pole opište z obrázku 5 znaků:

Kód pro ověření

 

 

 

 

 

Přihlášení k mému účtu

Uživatelské jméno:

Heslo: